E-ComProcessing - Genesis Gateway - Outage
Incident Report for E-Comprocessing
Postmortem

Dear partner,

Our investigation of the incident on Friday, June 05th 2020 between 09:52:00 and 10:30:10 UTC has shown that the routing problems were caused by arcane bug in the DB cluster software.

The bug is reported already to the software vendor but fix is not yet provided by them and there is no information at present whether this will be fixed in some of their future releases.

Please kindly note that the actions who triggered this bug to show up were done numerous times before on different occasions without this happening, which made it hard to detect and analyse.

We have updated our OS and DB patching procedures accordingly for this to not happen again, as a workaround for the bug that was encountered.

Please kindly accept our apologies for any inconvenience caused by this incident.

Kind regards,
E-comprocessing Tech Support Team

Posted Jun 24, 2020 - 17:29 UTC

Resolved
Dear Partner,

We have successfully identified the issue and resolved it.

Several database servers were not able to connect which lead to 503 Service Unavailable errors.

There was no financial impact for your customers and you can try re-submitting the transactions.

We are analyzing the root cause for a detailed postmortem.

Please accept our apologies for the caused inconvenience.

Kind regards,
E-ComProcessing Tech Support
Posted Jun 05, 2020 - 10:39 UTC
Investigating
Dear Partner,

Please kindly note that we are experiencing an outage with our gateway, which root cause is currently being investigated.

We will keep you updated on an ongoing basis, and inform you once the issue is resolved.

If you need further assistance or information, do not hesitate to contact us at Tech-Support@e-comprocessing.com.

Kind Regards,
E-ComProcessing Tech Support
Posted Jun 05, 2020 - 10:08 UTC
This incident affected: PRODUCTION (Genesis - admin console (PRODUCTION), Genesis - merchant console (PRODUCTION), Genesis - web payment form (PRODUCTION), Genesis - API (PRODUCTION)).