E-Comprocessing - Genesis Gateway - Temporary service disruption

Incident Report for E-Comprocessing

Resolved

Dear customer,

We can confirm that as of 00:50 UTC, the external issue that was affecting partially the payment processing, is now resolved.
After thorough investigation, we identified that the slow response times were caused by intermittent timeouts from our external card processor. We are actively following up with them to receive the root cause for the slow response times.
All affected services are now fully operational.

We appreciate your understanding, and please accept our apologies for any inconvenience caused.

Should you have any questions or require further assistance, please do not hesitate to contact our Tech Support team at tech-support@e-comprocessing.com

Kind regards,
E-Comprocessing Tech Support team
Posted Aug 27, 2026 - 01:53 UTC

Investigating

Dear partner,

Please be advised that a temporary external network issue was identified around 00:23 UTC with one of our card processors.

Our detailed analysis has shown abnormal behaviour of one of our external providers, which was affecting partially the payment processing.

Please accept our apologies for any inconvenience caused.

Kind regards,
E-Comprocessing Tech Support team
Posted Aug 27, 2026 - 01:52 UTC
This incident affected: PRODUCTION (Genesis - API (PRODUCTION)).