Genesis Gateway - Intermittent Outage causing SSL Certificate Errors
Incident Report for E-Comprocessing
Resolved
Dear Partner,

Please note that the issue with the SSL certificate errors was caused by a recently expired SSL cert in our certificate chain. None of our SSL certificates had any issues by themselves, nor have they been expired. We have successfully replaced the expired 3rd party certificate in the SSL certificate chain, and you should not experience any further issues. We are checking regarding that incident with our SSL certificate issuer regarding not sent notifications and what caused the problem their end.

This issue has impacted only a very small fraction of traffic. We sincerely apologize for any inconvenience caused.

If you notice any errors in the requests to us, please notify us immediately at Tech-Support@e-comprocessing.com.

Kind Regards,
E-ComProcessing Tech Support
Posted May 30, 2020 - 14:10 UTC
Identified
Dear Partner,

Please note that we are experiencing a partial outage with our gateway.

You might experience SSL Certificate errors when trying to submit transactions to our gateway. We have found the root cause of the issue and are currently working on the resolution.

If you need further assistance or information, do not hesitate to contact us at Tech-Support@e-comprocessing.com.

Kind Regards,
E-ComProcessing Tech Support
Posted May 30, 2020 - 12:29 UTC
This incident affected: PRODUCTION (Genesis - web payment form (PRODUCTION), Genesis - API (PRODUCTION)).